Metapo

your personal robot that will sweep and vacuum for you
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log inLog in  

Share | 
 

 Battery does not seem to hold a charge

View previous topic View next topic Go down 
AuthorMessage
mexicanrobot



Number of posts : 2
Registration date : 2009-12-27

PostSubject: Battery does not seem to hold a charge   2009-12-27, 6:14 pm

I have charged my battery and yet when i disconnect it the light stays on long enough to beep, turn the wheels and then all goes dead. Can you tell me how to check if the problem is with my battery or the charger and where to get replacements. I have looked all over the web with no luck!! I miss my vacuum!
Back to top Go down
View user profile
mexicanrobot



Number of posts : 2
Registration date : 2009-12-27

PostSubject: Re: Battery does not seem to hold a charge   2009-12-27, 6:16 pm

Sorry I forgot to mention I have a cleanmate 365 QQ-1
Back to top Go down
View user profile
ScoobaMan

avatar

Number of posts : 10
Age : 58
Location : Fredericton, New Brunswick, Canada
Registration date : 2008-12-14

PostSubject: Re: Battery does not seem to hold a charge   2009-12-31, 3:33 pm

mexicanrobot
replacement batteries can be found here if you live in Canada or USA.
http://www.robotshop.ca/home/products/personal-domestic-robots/robot-vacuums/infinuvo-cleanmate-robot-vacuum/index.html
Try plugging if the charger and leave it undisturbed for 3 days. Sometimes that will improve the battery performance. You didn't mention how old the battery is, if it's getting close to 2 years it's probably the battery.
Look in the owners manual and see if it says the output form the charger.
Back to top Go down
View user profile
RoboVac



Number of posts : 1
Registration date : 2010-05-18

PostSubject: Source for QQ-1 batteries?   2010-05-18, 11:23 pm

The link above doesn't have QQ-1 batteries (only QQ-2). Or can I put a QQ-2 battery in my Cleanmate 365 QQ-1?

Thanks!
Back to top Go down
View user profile
ScoobaMan

avatar

Number of posts : 10
Age : 58
Location : Fredericton, New Brunswick, Canada
Registration date : 2008-12-14

PostSubject: Re: Battery does not seem to hold a charge   2010-05-21, 4:45 pm

The battery for the QQ2 should work in the QQ1, the chargers for both models have the same specs (battery charger DC output 22V 1A,120V AC input) The difference in the batteries is the QQ1 uses a NiCD and the QQ2 uses a NiMH.
You should be OK.
Back to top Go down
View user profile
Sponsored content




PostSubject: Re: Battery does not seem to hold a charge   

Back to top Go down
 
Battery does not seem to hold a charge
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Metapo :: Technical Support Discussion :: Technical Issues & Solutions for QQ-1-
Jump to: